Crash in Skyranger Post-mission

Post Reply
unthoughtwords
Posts: 4
Joined: Mon Mar 25, 2019 9:13 pm

Crash in Skyranger Post-mission

Post by unthoughtwords » Mon Mar 25, 2019 9:33 pm

Long War 1.5, PC/Windows 10

Mod List
  • Parcel Maps EC (Vanilla)
    Commanders Choice [WotC & Vanilla]
    Mgee's Maps
    Doctor_Mandarbs_Map-Pack
    Vindictus Male Hairstyles
    More Clothes Options
    Bandanas and Headbands
    Expanded Mission Names
    More Cities
    Perfect Information for the Long War
    Overwatch All/Others
    More Nations Mod
    GrimStyleArmor
    World Expansion Project: Advent
    Evac All
    More Armor Colors
    Multiple Piercings
    [LW2 CMP] International Voice Pack
    Capnbubs Accessories Pack
    [X2] Military Camouflage
    More Maps Pack [Non WotC]
    Maps by Vozati [Vanilla Edition]
    Full Character Customisation
    Alternative Prop Positions
    Gotcha Again
    Additional Icons
    Even More Maps!
    Faster Psi Lab Training [WotC + Vanilla]
    Warhammer 40K Guardsmen Armor
    Ammo Pocket Fix
    Ammo and Vest Slots
    Quick Soldier Info
    No Drop-Down Lists
    Robojumper's Squad Select
    Robojumper's Squad Select: LW2
    LW2: Better Squad Icon Selection
    LW2: Squad Insignias
    Long War 2
    Stop Wasting My Time - Legacy
I am getting an every-time, consistent error in my ongoing ironman campaign, where after a mission the game will freeze momentarily and then shortly after CTD in the Skyranger. Initially (last week), coming back to XCOM2/LW2 after a long time, I was unable to start a new campaign due to this issue consistently happening after Gatecrasher any time I tried to start a new campaign. I found the steps online to remedy it - clear save files, clear config, and verify integrity of game files (two files were replaced), and after doing that plus tidying up my mod list a little it all ran smoothly, until the current point in my campaign - which now seems dead in the water because I cannot successfully leave this particular mission.

If it's relevant, I'm in the early-mid game (Octoberish iirc, Mag-level technology, two regions liberated, eight total contacted, currently infiltrating the Blacksite with a different squad) and the mission was a Dark VIP capture/kill. I've had the same issue several times, including using the restart mission console command and other quick cheats to try out both killing and capturing the VIP - both same result.

I've tried clearing my other save files and my config again, and re-verifying the integrity of the game files several times. I now get notified that one file (rather than the previous two) is unverifiable and being replaced every time I re-verify after a crash, but it doesn't achieve anything. I've noticed that the crash takes a long time to come, but the Skyranger animation is still playing throughout (it does its slow zoom thing alllll the way to the back of the Skyranger and then back in again) - that is to say, by the time the crash comes in a normal mission, the Skyranger animation would have already finished and we'd be back at the Avenger, so I don't think it's a case of a memory leak shooting down my game before it can load the Avenger? It feels more like it's getting 'stuck' on the Skyranger sequence (although I'm not an expert on stuff like this).

Fwiw, I've not added, removed, or changed any mods during the course of this run, and I don't think it's a mod update making one incompatible because I successfully completed a mission and made it back to the Avenger about an hour and a half/two hours before this bug first presented earlier today.

Is there anything I can do, or is this where I accept I was an idiot for playing ironman and call it quits?

johnnylump
Site Admin
Posts: 968
Joined: Wed Nov 11, 2015 4:12 am
Location: Colorado
Contact:

Re: Crash in Skyranger Post-mission

Post by johnnylump » Mon Mar 25, 2019 10:26 pm

If you want to dig out your log files in C:\Users<user name>\Documents\My Games\XCOM2\XComGame\Logs and post links here I'll try to take a look. The _logfile.log from the crash folder or the launch.log if it's from your most recent play should have some clues.

Beyond that, about all I can suggest is pulling mods. I'd start with ones that affect gameplay (as opposed to maps and cosmetics) that weren't made for LW2 ... these look particularly suspicious to me:

Faster Psi Lab Training [WotC + Vanilla]
Ammo Pocket Fix
Ammo and Vest Slots

unthoughtwords
Posts: 4
Joined: Mon Mar 25, 2019 9:13 pm

Re: Crash in Skyranger Post-mission

Post by unthoughtwords » Mon Mar 25, 2019 10:52 pm

Thanks for the response - and for all your hard work on the mod, it's a magnificent play experience!

https://www.dropbox.com/s/t0e5bedmo36jh ... e.log?dl=0

Hopefully that's accessible - that's the crash log file from my last try. It should be almost all relevant as the autosave from which I reloaded was just before evac, so most of what's logged should be the Skyranger sequence and subsequent crash.

Re: pulling mods, is there any logic I should be applying based on what might have changed in game, given that the mod list is unchanged from when it was running stable? Or should I just go blind trial and error beyond those few you've flagged (the ammo slot pair are a package which the author claims are LW2 compatible, although can accept they might well be wrong!)

johnnylump
Site Admin
Posts: 968
Joined: Wed Nov 11, 2015 4:12 am
Location: Colorado
Contact:

Re: Crash in Skyranger Post-mission

Post by johnnylump » Mon Mar 25, 2019 11:22 pm

In pulling mods, just do one at a time. If they say it's LW2 tested then I'd move it down the list.

FWIW, the last errors in the log are

[0271.99] Warning: Warning, Unable to load package (C:\Program Files (x86)\Steam\steamapps\workshop\content\268500\1200679870\Content\VindictusMaleHair.upk) PackageVersion 845, MaxExpected 845 : LicenseePackageVersion 120, MaxExpected 108.
[0272.02] Warning: Warning, Failed to load 'SwfMovie gfxInterfaceMgr.debugscreen': Unable to load package (C:\Program Files (x86)\Steam\steamapps\workshop\content\268500\1200679870\Content\VindictusMaleHair.upk) PackageVersion 845, MaxExpected 845 : LicenseePackageVersion 120, MaxExpected 108.

I'm not sure if this error is sufficient to CTD, but I'd def start by pulling the "Vindictus Male Hairstyles" mod. Looking at the mod page, some others have reported issues with LW2. (I'm not sure what pulling a mod with someone's hair that's in the mission will do -- hopefully just make them bald until you can get to the character editor)

unthoughtwords
Posts: 4
Joined: Mon Mar 25, 2019 9:13 pm

Re: Crash in Skyranger Post-mission

Post by unthoughtwords » Tue Mar 26, 2019 12:00 am

Good spot! I stopped running Vindictus Male Hairstyles and the Skyranger loading sequence was still unusually long and choppy but I did manage to progress back to the Avenger - thanks :D.

Bizarrely, none of the mission squad (or any members of my other squads) had any of the hairstyles from the offending mod, at least as far as I could tell when I went over them back on the Avenger. I didn't check the rest of my barracks though, admittedly.

Anyway, fingers crossed it holds up - thanks again for your help!

prokolyo
Posts: 59
Joined: Thu Nov 15, 2018 6:29 am

Re: Crash in Skyranger Post-mission

Post by prokolyo » Tue Mar 26, 2019 2:51 am

Huh, that's peculiar. I've played several campaigns with Vindictus female hair mods with no problems, but I guess the male one is a problem...

unthoughtwords
Posts: 4
Joined: Mon Mar 25, 2019 9:13 pm

Re: Crash in Skyranger Post-mission

Post by unthoughtwords » Tue Mar 26, 2019 9:03 am

I had no idea there was a female hair counterpart :lol:

prokolyo
Posts: 59
Joined: Thu Nov 15, 2018 6:29 am

Re: Crash in Skyranger Post-mission

Post by prokolyo » Tue Mar 26, 2019 4:10 pm

Two even :) And no one ever makes male stuff so I did try the male vindictus, but didn't like them at all and uninstalled them right away.

Post Reply