Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post Reply
vool
Posts: 3
Joined: Wed Jan 09, 2019 4:31 pm

Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by vool » Wed Jan 09, 2019 5:34 pm

Since yesterday I get a reproducable crash to the desktop when I enter the Geoscape. Before that everything was fine. The crash comes with this error:
Pure virtual function being called while application was running (GIsRunning == 1)
So far I believe that LW2 has an issue with the .NET Framework 3.5. and 4.7.2 update that came on Patch Tuesday yesterday (01/08/2019) with Windows Update, because the only mod I'm using is LW2, and if I deactivate it and load a vanilla savegame, everything works fine. Granted, I can't rule out savegame corruption (can't try an earlier save of this campaign due to Iron Man), but IMO that's unlikely because before the new .NET runtime I had no problems. Also, I never had savegame corruption so far.

I tried verifying the local Steam files, but no reinstall yet.

I noticed that the 4.5.1 folder in Program Files (x86)\._._.\XCOM2\_CommonRedist\DotNet is empty now, and there's a new 4.5.2 folder with the date of this recent Windows Update. That new folder has the new runtime files. Maybe I could find the old files, copy them back to the 4.5.1 folder, and then delete the new 4.5.2 folder? Would that force XCOM2 to use the old .NET runtime again?

EDIT: Because of the different version number of the .NET update I tried renaming the new 4.5.2 folder to 4.7.2, thinking that maybe the update was bungled. Didn't change anything, though.

I'm using:
- LW2 1.5 with latest hotfix
- Windows 10 (1809, Build 17763.253)
- No mods (other than LW2)

Does anyone else have the same problem, and maybe found a solution?

Thanks in advance!
Last edited by vool on Fri Jan 11, 2019 1:49 am, edited 1 time in total.

User avatar
johnnylump
Site Admin
Posts: 975
Joined: Wed Nov 11, 2015 4:12 am
Location: Colorado
Contact:

Re: Crash to desktop with new .NET runtime 4.7.2

Post by johnnylump » Wed Jan 09, 2019 10:28 pm

A pure virtual function crash can be lots of things; you'd probably want to find the game logs to see what's going on.

I don't have any immediate suggestions but will be keeping an eye on this thread.

vool
Posts: 3
Joined: Wed Jan 09, 2019 4:31 pm

Re: Crash to desktop with new .NET runtime 4.7.2

Post by vool » Thu Jan 10, 2019 1:08 pm

Thanks for replying. Unfortunately I didn't find any information on how to interpret the game logs. The launch.log doesn't even contain the pure virtual function error, but lots of "duplicate NetIndex" errors.

In any case, the launch.log is in the attachments, if someone is willing to take a look.
Attachments
Launch.zip
Launch.log
(33.56 KiB) Downloaded 22 times

User avatar
johnnylump
Site Admin
Posts: 975
Joined: Wed Nov 11, 2015 4:12 am
Location: Colorado
Contact:

Re: Crash to desktop with new .NET runtime 4.7.2

Post by johnnylump » Thu Jan 10, 2019 10:50 pm

The last thing in there says something about autosave issues. Have you tried a new campaign?

vool
Posts: 3
Joined: Wed Jan 09, 2019 4:31 pm

Re: Crash to desktop with new .NET runtime 4.7.2

Post by vool » Fri Jan 11, 2019 1:15 am

Good call, sir. I started a new LW2 campaign, entered the Geoscape after Gatecrasher, and had no issues. Looks like the runtime stuff was just a coincidence and I had my first corrupt savegame.

No more Iron Man for me from now on, I guess.. because I couldn't even go back to an older save from my backup, because when I start the game the local file is overwritten with the corrupt one from the Steam cloud. :(

Thanks for the help!

EDIT: Ha! I managed to revert to an uncorrupted savegame from my backup by starting Steam, waiting for the cloud sync to finish, and *then* overwriting the savegame again.

Rittstar
Posts: 7
Joined: Thu Jul 20, 2017 6:45 am

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by Rittstar » Sun Jul 21, 2019 7:02 am

hi i have the same error message in my new campaign

i have a lot of LW2 related mods and some others

the game loads and now a new mission pops up, once i press to send the Avenger to squad up the mission it crashes with the same error message like thread OP "Pure virtual function being called while application was running (GIsRunning == 1"

so i try to not taking this mission and wait for a new one where the same issue occurs

can someone look into this?

thank you in advance
Attachments
XCom-CL234736-2019.07.21-07.44.17_Save-Rename-To-Save0-For-Load.zip
(462.21 KiB) Downloaded 6 times
XCom-CL234736-2019.07.21-07.44.16_Logfile.log.zip
(39.45 KiB) Downloaded 5 times
Launch.zip
(39.42 KiB) Downloaded 4 times

User avatar
johnnylump
Site Admin
Posts: 975
Joined: Wed Nov 11, 2015 4:12 am
Location: Colorado
Contact:

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by johnnylump » Sun Jul 21, 2019 4:41 pm

There's no common thread between these errors. It's a generic error message.

The last part of Launch.log suggests errors in Robojumper's Squad Select.

Rittstar
Posts: 7
Joined: Thu Jul 20, 2017 6:45 am

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by Rittstar » Mon Jul 22, 2019 12:07 pm

okay thank you, seems i untick this one by mistake, works again

Ranger34
Posts: 8
Joined: Tue Oct 24, 2017 3:53 pm

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by Ranger34 » Fri Jul 26, 2019 1:19 am

Hi, similar problem here - after loading savegame, crash with pure virtual function call when I'm trying to enter geoscape.
I'm in late game, have plasma already, so it's quite unfortunate.

Long War 1.5
Windows 7, Steam version
Perfect information for the long war + Gotcha again
Logs attached + I have savegame if needed, too large for attachment

Thanks in advance!
Attachments
Launch.zip
(39.24 KiB) Downloaded 2 times
XCom-CL234736-2019.07.26-03.33.41_Logfile.zip
(39.25 KiB) Downloaded 4 times

Ranger34
Posts: 8
Joined: Tue Oct 24, 2017 3:53 pm

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by Ranger34 » Fri Jul 26, 2019 1:10 pm

Found cause of the problem - it's autosave when entering geoscape. Not only autosave, but manual saving just after loading causes same crash. Then i boosted infiltration for one of pending missions, supply raid, started it, and tactical saves works! I requested evac, did some fighting waiting for it, aborted mission. After that, saves from the Avenger screen working again! Quite mysterious bug.

Here is savegame if anyone interested:
https://www.dropbox.com/s/zp8w39l122hk131/save38?dl=0
For me it crashes when I'm trying to save again after loading.

RookieAutopsy
Posts: 80
Joined: Sat May 13, 2017 9:35 am

Re: Crash to desktop with new .NET runtime 4.7.2 (SOLVED - corrupt savegame)

Post by RookieAutopsy » Sat Jul 27, 2019 7:49 pm

Just had the same thing in the final Leviathan room on my first Commander/Ironman run that made it that far. Start of turn autosave could be the cause. Had to console in a 1 HP Avatar to complete the game :(

Post Reply